Which PHP Extensions Are Required to Run a WordPress Site?

Just moved from Shared to self-managed VPS hosting or minimizing the software needed to run a WordPress site.

Most of us suffered from a Question: Which PHP modules are needed to install and run WordPress as a fully operational website.

Just for the sake of the answer, I tried a dry run and moved this site to another server with a plan to install all the latest web software like Nginx’s latest version, PHP7.4 (heard so much +ve), and MariaDB.

I installed everything except PHP. Then I installed and tested the most required PHP modules one by one to run the WordPress admin.

PHP Modules

Note: I have installed like php7.4-{module}, in the below list I have removed the version number to make you understand better.

  • php-fpm
  • php-cli
  • php-common
  • php-curl
  • php-gd
  • php-imagick
  • php-mbstring
  • php-mysql
  • php-xml
  • php-zip

In my setup, I do not need anything more, and whichever extra required is installed by their required dependencies.

You can also check the latest WordPress’s Site Health feature available under Tools menu to check what is missing and whatnot.

Site Health
Site Health (Tools menu)

So IMO, you do not need anything more than above.

Published by AtulHost

Atul Kumar Pandey is a creative blogger who loves experiments with the latest tech trends like automation, artificial intelligence, data science, cloud computing, edge computing, hardware as well as networking, and the internet of things.

4 comments on Which PHP Extensions Are Required to Run a WordPress Site?

  1. Thanks for the list Atul, I got what I was looking for my minimal server setup. But I am getting issue with one or two extensions, they are not available with PHP 7.4, what should I do in that case?

Leave a Reply to Jendrik Cancel reply

Your email address will not be published. Required fields are marked *